Problems logging in to CIT service

Incident Report for GMO GlobalSign

Resolved

We have identified and resolved the issue, which was preventing communication between CIT and the authentication service. CIT is now operational again.
Posted Dec 22, 2022 - 16:10 UTC

Update

We are engaging with our technology partner to help investigate and resolve the issue, as we have not been able to identify the problem from our side. We will post updates as we get more information.
Posted Dec 20, 2022 - 08:15 UTC

Investigating

We are currently investigating an issue with CIT (https://cit.globalsign.com) which is causing a blank page when logging into the portal. We will post as soon as we have further information.
No other Atlas or GCC services are affected.
Posted Dec 14, 2022 - 16:00 UTC