GCC Certificate Issuance

Incident Report for GMO GlobalSign

Resolved

The GCC Certificate Issuance service has been fully restored and is operating normally.
Posted Nov 25, 2025 - 12:33 UTC

Monitoring

Service for GCC Certificate Issuance has been restored, and customers should now be able to issue certificates normally. We are closely monitoring the system to ensure stability. The root cause is still under investigation, and we will provide updates as soon as more information is available.
Posted Nov 25, 2025 - 08:49 UTC

Investigating

We’re currently investigating reports of a potential service interruption with GCC Certificate Issuance. The root cause is currently unknown. We understand the issues this may be causing and are working hard to resolve the problem as soon as possible.
Posted Nov 25, 2025 - 08:05 UTC
This incident affected: GCC (Certificate Issuance).