The provider reports the issue as resolved, and we are not seeing any further interruptions in our monitoring so are considering the incident resolved as well.
Posted Sep 16, 2026 - 14:46 UTC
Monitoring
The provider's fix is being rolled out region by region. We have not seen any impact to the portal in the last 40 minutes, but are continuing to monitor closely until given the all-clear.
Posted Sep 16, 2026 - 12:10 UTC
Update
The provider has identified a fix and is rolling it out, we are monitoring closely and will confirm when we see fully stability returned.
Posted Sep 16, 2026 - 11:04 UTC
Update
Our provider have updated us that they are currently testing a fix for the problem and are currently monitoring. We will update once it is confirmed that the resolution has been successful.
Posted Sep 16, 2026 - 09:20 UTC
Identified
We are experiencing intermittent timeouts and errors on the Atlas portal. This relates to an upstream problem at one of our SaaS providers. We are monitoring the situation and will provide updates as we get them. The backend APIs (certificate issuance, DSS, TSA, etc) are unaffected.