Problems accessing www.globalsign.com

Incident Report for GMO GlobalSign

Resolved

The issue has been resolved and the marketing websites are fully available globally.
Posted Jul 17, 2025 - 13:08 UTC

Investigating

We are currently investigating an issue which is affecting access to the www.globalsign.com marketing site. Core service functionality is not affected.
Posted Jul 17, 2025 - 12:47 UTC
This incident affected: Marketing Websites.