Atlas Portal usage display problems affecting some customers

Incident Report for GMO GlobalSign

Resolved

Following an extended period of close monitoring, the team have confirmed that the issue is resolved.
Posted Apr 29, 2026 - 08:53 UTC

Monitoring

The team have successfully deployed the fix and we are closely monitoring to ensure that the issue is resolved for all affected customers.
Posted Apr 23, 2026 - 19:25 UTC

Update

Our development team are currently testing a fix for the issue. We will provide further updates as this is confirmed ready for production release.
Posted Apr 20, 2026 - 16:17 UTC

Identified

We are aware of some further issues relating to the display of usage in the Atlas portal, affecting a small number of customers. The development team are actively working on a fix for affected customers.
Certificate issuance and use of the APIs themselves is not affected.
Posted Apr 16, 2026 - 16:03 UTC
This incident affected: Atlas (User Portal).