Important GCC System Maintenance
Scheduled for Jan 22, 2023, 09:00 - 12:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Nov 24, 2022 - 11:43 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Nov 24, 2022 - 11:42 UTC
Scheduled
A maintenance window is scheduled for Sunday, January 22nd.

Certificate life cycle management (including ordering, reissuing and renewing) will not be available via the GlobalSign Certificate Center (GCC) or GCC APIs for ~3 hours. For real time updates, please view and subscribe to our status page here.

Services Affected: GCC UI, GCC API, Site seal, JCAN UI
- Access to GCC UI to request, issue or revoke certificates will be unavailable.
- Certificate issuance by API will be unavailable.
- Access to URL for download certificates will be unavailable.
- JCAN system unavailable
- Displaying site seal on customer’s website will be unavailable.
Posted Nov 24, 2022 - 11:41 UTC
This scheduled maintenance affects: GCC (GCC User Portal, Certificate Issuance).