Some customers may see incorrect usage in the Atlas portal

Incident Report for GMO GlobalSign

Update

The development team are still working on resolving the issue. We will continue to post updates as they become available
Posted Mar 31, 2026 - 18:06 UTC

Update

The development team are deploying a fix which should restore proper visualisation of usage for some sets of customers. A fix for remaining affected customers is expected to be deployed tomorrow.
Posted Mar 30, 2026 - 16:29 UTC

Identified

We are aware that following a portal update, some customers may see incorrect usage data displayed. Our development team are currently validating the fix and we expect this to be deployed on Monday.
Certificate issuance and use of the APIs themselves is not affected.
Posted Mar 27, 2026 - 19:00 UTC
This incident affects: Atlas (User Portal).