Increased error rate on Atlas TSA service

Incident Report for GMO GlobalSign

Resolved

No further errors have been recorded.
Posted Nov 25, 2025 - 13:25 UTC

Monitoring

We have found a way to prevent the errors for affected customers and have implemented this while we confirm and resolve the root cause. We will keep a close eye on error levels on the service over the next 24 hours.
Posted Nov 24, 2025 - 17:31 UTC

Update

We are continuing to investigate this issue. The problem is limited to customers using Atlas Timestamping with the Japanese Qualified Timestamp service provided by our partner in Japan. However, we are yet to identify the root cause for the high failure rate of these timestamps.
Posted Nov 24, 2025 - 17:00 UTC

Investigating

We are currently investigating a slightly increased error rate on the Atlas TSA service, resulting in customers receiving HTTP 503 errors in a small number of cases. Retrying failed requests should result in a successful response. We will provide updates as we identify the cause.
Posted Nov 21, 2025 - 16:41 UTC
This incident affected: Atlas (Time Stamping).