Problem sending domain validation emails from Atlas

Incident Report for GMO GlobalSign

Resolved

The problem has been resolved.
Posted Sep 11, 2025 - 06:54 UTC

Update

We are continuing to work with our service provider on resolving the issue.
Posted Sep 10, 2025 - 17:24 UTC

Identified

We have identified the issue and are working with our email relay provider to resolve.
Posted Sep 10, 2025 - 12:03 UTC

Investigating

We are currently investigating an issue which seems to be preventing domain validation emails being sent from Atlas - we are seeing a number of errors in our logs relating to email submission.
Posted Sep 10, 2025 - 11:01 UTC
This incident affected: Atlas (Certificate Issuance).