GCC Data Center migration
Scheduled for Feb 21, 00:00 UTC  -  Feb 22, 00:00 UTC
Update
The GCC Data Center migration will be postponed to Sunday, February 21, 2021 due to constraints and travel restrictions from the Covid-19 pandemic.

Delaying the migration will allow for better user acceptance testing to ensure service stability and minimal customer disruptions.

As a recap and as part of GlobalSign’s on-going commitment to improve the security, availability and high scalability of our cloud-based services, we are excited to announce a major investment in an additional state of the art datacenter. Our Infrastructure and Engineering teams are planning a migration from one of our current datacenter locations to the new facility (both located in Singapore). The team is working towards a guarantee of minimal to no service disruptions. The migration will now take place on Sunday, February 21, 2021.
Posted Jan 20, 2021 - 10:49 UTC
Scheduled
As part of GlobalSign’s on-going commitment to improve the quality and availability of our cloud-based services, we are excited to announce a major investment in an additional state of the art datacenter, keeping in mind our customer's requirements for security, availability and high scalability.

The GlobalSign Infrastructure and Engineering teams are planning a migration from one of our current datacenter locations to the new facility (both located in Singapore). The team is working towards a guarantee of minimal to no service disruptions. Given the magnitude of the migration, we are informing all customers in advance that the migration will take place the week of January 25, 2021.
Posted Dec 24, 2020 - 14:59 UTC
This scheduled maintenance affects: GCC (Certificate Issuance, OCSP & CRL Services, Time Stamping).