GlobalSign Certificate Inventory Tool unavailable

Incident Report for GMO GlobalSign

Resolved

Following work by our service provider, full redundancy and capacity has been restored on the system.
Posted Jun 29, 2022 - 18:52 UTC

Monitoring

We have found and implemented a fix, so CIT is available again. We are continuing to work with our service provider to regain full redundancy on the service.
Posted Jun 28, 2022 - 13:22 UTC

Identified

The Certificate Inventory Tool (https://cit.globalsign.com) is currently unavailable. We have identified the issue, which relates to a problem at our third party service provider. We will be working with them to get the service back online as soon as possible.
Posted Jun 28, 2022 - 12:25 UTC