Intermittent certificate issuance failures on GCC

Incident Report for GMO GlobalSign

Resolved

The issue has been confirmed as resolved.
Posted Mar 17, 2026 - 08:30 UTC

Monitoring

We have seen a brief issue with issuance on GCC causing some certificate requests to fail or be delayed over the last 15-20 minutes. The team are working to ensure the problem is resolved.
Posted Mar 17, 2026 - 08:14 UTC
This incident affected: GCC (Certificate Issuance).