Issue with Atlas Qualified TSA service

Incident Report for GMO GlobalSign

Resolved

No further errors have been seen.
Posted Sep 25, 2026 - 11:57 UTC

Monitoring

The problem with the failing TSA server has been resolved and we are continuing to monitor the situation closely to ensure no more errors occur.
The problem resulted in a small number of spikes in HTTP 503 responses, across all TSA services. This caused a small number of upstream errors to be returned by DSS as well.
Posted Sep 25, 2026 - 10:47 UTC

Identified

We have identified a problem with one of our TSA servers. The server has been removed from the pool so shouldn't cause further issues, and one of our engineers is working to restore it to service now.
Posted Sep 25, 2026 - 10:23 UTC

Investigating

We are investigating an issue affecting that Atlas Qualified TSA service which may be causing intermittent errors. We will post more information once it is available.
Posted Sep 25, 2026 - 10:16 UTC
This incident affected: Atlas (Time Stamping).